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1. AD Mentor at a Glance
ADMentor is an add-in to Sparx Enterprise Architect Version 10 (and higher) that supports
the sharing of architectural decision knowledge across projects:

Context matters when it comes to experience sharing; therefore simplistic best
practices rules and design-by-authaority are bound to fail in the real world. This
makes architectural decision knowledge particularly precious. Howewver, such
knowledge changes frequently, and architecture documentation budgets typically
are very limited. Therefore, knowledge reuse by chance is not going to happen.

Decision guidance models, created with the ADMentor tool, fill the gap between
static and stale reference architectures and patterns and retrospective decision
capturing in mesting protocols, project wikis, or software architecture documents,

Source: ADMentor project website, hitps://www.ifs.hsr.ch/index.php?id=13201

The key features of ADMentor are:

Problem space modeling: recurring design decisions, options to be considered (as
envisioned in this IEEE Software/InfoQ article) - providing a checklist effect
Solution space modeling: decisions made and their rationale — yielding a continuous
decision log

Model tailoring (context-specific filtering), decision backlog management

Rich text editing, model refactoring, reporting via Enterprise Architect integration
Decision capturing with lightweight decision capturing templates such as Y-
statements (as introduced in this IEEE Software/InfoQ article)

Question, Option, Criteria (QOC) diagram support

Sample guidance models compiling decisions that recur in cloud application design
and workflow design

ADMentor’s technology highlights include:

UML Profile and MDG Technology with state-of-the-art Architectural Knowledge
Management (AKM) semantics, optimized for decision modeling with reuse
Model tailoring and filtering capabilities based on Tagged Values (UML extension
mechanism)

Decision space analytics

RESTful HTTP interface for tool integration
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2. Install AD Mentor

1.1 Software Prerequisites
e Sparx Enterprise Architect (EA) Version 10 or higher
e Microsoft .NET Framework 4.5
(Download at http://www.microsoft.com/en-us/download/details.aspx?id=30653%20)

1.2 Installation
1. Execute “ADSetup.msi”.
2. Follow the installation wizard.

Although you have to select an installation folder during the setup, the installation will not
create any files in this folder. The setup process only adds the required libraries to the
system’s Global Assembly Cache and registers the Enterprise Architect Add-In.

2 Model a Reusable Problem Space

2.1 Create a new Problem Space
1. Navigate to “Project” > “New Model...” (or press Ctrl + Shift + m).
2. Select the “Problem Space” model from the “AD Mentor” technology.

-
(& Model Wizard ﬁ

Model Patterns | Application Patterns | VEA Examples |

Select model(s) to add to your project

»

Technology Mame

Basic UML 2 Technology
Simple UML Views [~ Solution Space

Core Extensions |— AD Mentor Demo

MDG Technology Builder
@ AD Mentor

[Z} Arceis

[Ej ArchiMate

(=i BPmN 1.1

=} BPMN 2.0

5 Bl

m

2.2 Add Problems/Options to the Problem Space

2.2.1 Using the Toolbox
1. Open a “Problem Space” Diagram.
2. Drag and drop the desired element type to the diagram.

More toals... |

= Elements

<> Problem

2 Option

E3  Problem Space Package
=/ Problem Space Connectors
#  Addressed By

#  Raises

-1 Suggests

- Conflicts With
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Using Quick Links

Select an existing element in a Problem Space diagram, e.g. a Problem or an Option.
Click on the Quick Linker arrow at the top right corner of the shape and drag it to the
position where the new element should be created.

W M
7
il

Problem

Rl S

Z
[ ]
7
7z
/
= o
et e

Select the connection type that should be used to associate the new element with the

selected element, as well as the type of the new element (e.g. Option or Problem).
9%: A W '/////:;I
: 7
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W M A W Addressed By F Option
Raised By .
Raises k
Common ¥
Help...

The above quick link reads as “Problem 1 should be addressed by a new Option”.

Quick links can also be used to connect two existing elements.

For more information on quick links, see
http://www.sparxsystems.com/enterprise architect user gquide/10/modeling basics/quick

links.html.

3 Create a Tailored Problem Space Export

A Problem Space may contain information that should not be used to create a concrete
solution. This information may include confidential data or information that is clearly not
related to the solution. This is why AD Mentor offers a feature to export a subset of a
Problem Space that is specifically tailored to the needs of a particular solution project.

1.
2.

3.

Right click on a package containing Problem Space items in the Project Browser.
Select the “Extensions” > “AD Mentor” - “Tailor Problem Space” menu item. AD

Mentor may now take up to a minute, or more for very large models, to calculate the
required information.

Project Browser x
BmHE R B-E Y @
4 gy Model
a| |2 Problem Spac = ) s . -
ﬁ Problem ‘ Extensions ‘ AD Mentar ‘ Locate Option/Problem
p
O <adOption | & properties Decision Viewpoints v Establish Dependencies from Problem Space
. D -

9 «Ed?ptlﬂﬂ P D Graphs Tailor Problem Space

Adapt the filter that you want to apply on the Problem Space in the upper half of the
“Tailor Package Export” dialog. The lower half of the dialog lists the entities that
match the selected filter and will be exported when clicking “Export”. You can also
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select/deselect individual entities to specify an even finer grained tailoring of the
problem space.

-l Tailor Package Export

Entity Filter:

B rtcleciual Popery g

=[] Keyword

|:| Knowledge Provenance

-] Metatype

B[] Option State

--DOrganisatinnaI Reach

B[] Cwner Rale

B[] Problem State

|:| Project Stage

[-[7] Refinement Level

Export Entities:

=-[¥] Package: <<Package:=> Problem Space
Element: <<Option=> Option1

: <<Dptionz> Option2

: ««Problem:» Problem

: ««Problem» Problem
: <<ADMentor::Problem Spaces> SubSpace

4. When you click on “export”, AD Mentor asks for a location for the XML export.
Choose an appropriate path and filename and start the export by clicking “Save”.
Depending on the size of the Problem Space, the export may take several seconds.

The entity filters allow selecting elements with desired properties. These properties include
the tagged values defined by ADMentor (see Section 10), keywords and other element
properties defined by Enterprise Architect and the type of the element.

The top-level nodes of the filter tree form a conjunction (logical and). Hence, elements must
match every selected top-level filter to be included in the export. The options in each top-
level filter are a disjunction (logical or). An element must match one of the selected
properties.

For instance, the following filter selection accepts elements that have an “Organisational
Reach” of “Division” and are in the “Project Stage” “Elaboration” or “Inception”:

&[] Option State
Iél--OrganisatiunaI Reach
: Divizion
--DOwner Role

|:| Problem State

EI Project Stage

: Elaboration

|:| Refinemert Lewvel

Diagrams and Packages are included in the export if they match the selected filter or they
contain elements that match a selected filter.

And finally, there is an additional rule, that an Option derives properties from a Problem
when these two elements are connected by an “isAddressedBy” relationship and the property
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is not present in the Option. For example, an Option does not have a “Project Stage” tag, but
derives its project stage tag from all Problems that are addressed by this Option.

3.1 Import a Tailored Problem Space into another Project
1. Open an EA Project file.
2. Right click on the Root Model in the Project Browser and select the “Import Model
from XMI...” menu item (or press Ctrl + Alt + [).

®

| BEEE wm @3-ty @

4| Uy Model
Extensions »
Package Control ]

Apply Auto Maming to Elements...

Add »

Rename Model...

Copy Package to Clipboard

Paste Package from Clipboard

(84 Find in Project Browser...
Expand Branch

Collapse Branch

| Import Model from XML Strg=Alt=] |
3. Enter the location of the tailored XML export file and click on “Import” to start the
import.

a. If you import the XMl into the same project file as the one used to generate
the export, you have to select the “Strip GUIDs” option to prevent collisions.

4 Create a Concrete Solution Space

4.1 Manually Populate a Solution
1. Create a new Solution Space (in the same way as you create a problem space, see
Section 2.1 for instructions).
2. Open the Solution Space diagram that is contained in the new Solution Space. You
can also create Solution Space diagrams manually.
3. Drag and drop items from the Problem Space into the Solution Space diagram.
 BEm%E h B-E- 4+ 8 @
7 a [ Model
Solution Space a |8 Problem Space
E Problem Space
(O «adOption= Optionl

(O «adOption= Option2
__-—O «adProblem:= Probleml

a |H] Solution Space
éf T Solution Space
4. Enterprise Architect should now open the “Paste Element” dialog. Select “Instance
(Object)” or “Instance (ADMentor::adProblemOccurrence)” in the “Paste as” drop

down menu (it doesn’t matter which of these two menu entries you choose). The
“Copy Connectors” checkbox has no implications on the outcome, and you can leave
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it as is. Confirm the element instantiation by clicking “OK”.

-
Paste Element ﬁ

Paste as: Instance (Object) -

|| copy connectors

Structural Elements: | Mo Embedded Elements

[Options v] [ 0K ][ Cancel ][ Help

5.

You can also automatically add instances of related Problems/Options to existing
Solution Space items: Right click on an Option/Problem Occurrence in a Solution Space
diagram and choose the “Extensions” > “AD Mentor” > “Establish Dependencies from
Problem Space” menu item.

DA - ® g 2| G 2 @

o

)
(Cpen)
7 Problem1 \4
? | Extensions 4 ‘ AreGIS 4
6’////////// et oDM v
@ Properties... Alt-Eingabe
GML 3
I‘E?l Lock Element...
— AD Ment 13 Locate Option/Probl
@ Feature and Compartment Visibility... Strg+Umschalt+Y | entor | e
Decision Viewpoints 3 | Establish Dependencies from Problem Space
e R — [ S

This will open the “Populate Dependencies Wizard”. You can use this wizard to create
instances of related elements from the Problem Space in the Solution. When you select
related elements and press “Create”, AD Mentor automatically instantiates them
accordingly and adds the new instances to the currently open diagram.

-
o2 Populate Dependencies Wizard ﬁ

| SelectAll | | Deselect All | | Creste || Cancel |

4.2 Automatically Instantiate a Complete Problem Space into a new

Solution
Right click on a package that contains Problem Space items in the Project Browser.
2. Select the “Extensions” > “AD Mentor” - “Create Solution Space from Problem
Space” menu item.

N

Project Browser x
BmEE . BE-E- +3 @
a @ Model
%% Problem §
a Déop er: | = omene v AD Mentar » | Locate Option/Problem
robl

O «adOp @ Properties... Decision Viewpoints Establish Dependencies from Problem Space
O «adOp) Package Control R Graphs 3 Tailor Problem Space

O «adPrg ‘ Create Solution from Problem Space

Package Browser 13
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3. Enter a name for the solution to be created and click “Create”.
Choose Name for New Solution @

My Project

[ Create II Cancel ‘

4. AD Mentor now creates a new Solution Space that contains instances of all Problems
and Options from the selected package including the according connectors and
diagrams. AD Mentor tries to reproduce instantiated diagrams as accurate as
possible and also includes references to other elements like notes or requirements
that were not instantiated. Unfortunately not all diagram objects can easily be copied.
For example embedded images are not supported.

5 Document the Decision Making Process

5.1 Update the Decision State of an Option Occurrence

1. Select an Option Occurrence in a Solution Space diagram.

2. Open the “Tagged Values” tab that appears near the properties editor (in the default
layout of the EA user interface, which can be customized by the user). If you can’t
find the tab, you can open it via the main menu under “View” > “Tagged Values” or
by pressing Ctrl + Shift + 6.

B o= X i@

= ADMentor:-adOptionOccurmence {(Option2)
Option State Eligible
¥Modelld ADMentor:2

= from Option2

=l ADMentor:-adOption
[Open) Inteflectual Prop...  Unrestricted
Froblem1 Knowledge Prov...

«adAddressedBye
«adAddressedBys

(Eligible) L] %
Optioni |

)
s

Zn

-

k

I @Prapelties @H-:utes %Tagged Values
3. Change the “State” value accordingly to your decision. AD Mentor will automatically
update the state of associated problems.

AD Mentor also offers a shortcut for documenting past decisions. Just select an Option
Occurrence and open in the context menu “Extensions” = “AD Mentor” - “Choose Selected
and Neglect not chosen Alternatives”. This will set the state of the selected Option
Occurrence to “Chosen” and the state of all other Options of the associated Problem
Occurrence that are not “Chosen” to “Neglected”.
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You can also neglect all options of a problem and set the problem to state “not applicable”
with a problem-level shortcut: “Extensions” - “AD Mentor” - “Neglect all Alternatives”.

5.2 Find not yet Decided Problem Occurrences

1.

2.

B

Right click on your Solution Space package in the project browser and select the
“Package Browser” - “Standard View” menu item.

Right click an item with stereotype “adProblemOccurrence” and choose the menu
item “Add Tag Value Column”.

Package Browser:: Package BrowserModel'\My Project

B X E A - 8% &Lt ©
MName Type Stereotype State

Bl Problem1 Chjsct adProble Properties...

Bl Option1 Object adOption Edit Motes [Ctrl=Shift=S5pace)
*u Create Linked Document Strg=Alt-D

¥ Add New Element

Find in Diagrams...
Find in Project Browser...

Bookmark Item...
Switch to Gantt View
Documentation 4

Sort Contents
Reload

| Add Tag Value Column

Select the radio button “Tagged Values from the selected Element” in the “Add Tag
Value Column” dialog.

Select the “Problem State” entry in the “Tagged Value” drop down and click “OK”.
The package browser now contains a column “Problem State” that displays the
decision state of Problem Occurrences. By dragging the “Problem State” column
header to the area labeled “Drag a column header here to group by that column” you
can group the package contents by the decision state. Additionally, you can specify

filters on the decision state by clicking the “Toggle Filter Bar” button#~" .

Further customization of the Standard View of the Package Browser is possible (this is
standard EA functionality). For instance, you can add some of the Tagged Values defined in
Section 10 to turn the Package Browser into a full decision backlog. To save and load such
customizations, go to the “Columns Layout” entry in the context menu of the Package
Browser.

6 Query Metrics on Problem and Solution Spaces

1.

Right click on a package in the project browser and select the “AD Mentor” ->
“Package Metrics”.
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2. AD Mentor will now calculate several metrics for you (this may take several seconds).

o5 Package Metrics l =NRCN X
s '
* Common
** Hements ]
** Packages 2
** Hements per Package Min 2 / Avg 2.50 / Max 3 3
* Problem Space i
"~ Problems 2

7 Validate Problem and Solution Spaces

AD Mentor provides several validation rules for Enterprise Architects built in validation
facility. Currently, the following checks are implemented:

¢ Warning: Problems without associated Options (via AdressedBy links)

¢ Warning: Options that are not associated with a Problem (via AdressedBy links)

e Warning: Options that address more than one Problem

e Warning: Problem Occurrences without associated Option Occurrences

e Warning: Problem Occurrences that are not associated to a Problem Occurrence

e Error: Problem Occurrences with a state that does not map to the states of the
associated Options (Inconsistent State)

e Error: Problem Occurrences with two or more chosen Options that are connected with
a “conflictsWith” connector (conflicting Options chosen).

e Warning: ADMentor entities with an outdated model version.

e Warning: Elements that are not part of any diagram

Perform the following steps to run EA’s validation:

1. Open “Project” = “Model Validation” - “Configure...” in the main menu.
2. Enable the “AD Mentor” validation rules and confirm with “OK” (you may want to, but
do not have to, deselect the other options).

.
Model Validation Configuration S — Ié]

Enabled Validation Rules

| Element: Well-Formedness

/| Element: Composition

/| Element: Property Validity

V| Element: OCL Conformance

/| Relationship: Well-Formedness
/| Relationship: Property Validity
| Relationship: OCL Conformance
V| Feature: Well-Formedness

/| Feature: Property Validity

| Feature: OCL Conformance

/| Diagram: Well-Formedness

| Requirements Management

| AD Mentor

| Select All | |Selectﬁone| [ OK ] | Cancel | | Help |

w

Select the package that you want to validate in the project browser.

4. Start the validation via “Project” > “Model Validation” - “Validate Selected” (or Ctrl +
Alt + V)

5. The validation writes all found issues to the “System Output” tab. This may take

several seconds or even minutes, depending on the size of the selected package.
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8 FAQ

Which versions of Enterprise Architect are supported by the AD Mentor Add-
In?

The current release is targeted for Enterprise Architect (EA) Version 10. EA Version
11 is supported, but behavior may slightly differ from the description in this
walkthrough.

Can | use AD Mentor and Decision Architect for EA
(https://decisions.codeplex.com/) in the same project?

Yes, AD Mentor is designed to cause as few inferences with other add-ins as
possible. However, there is (currently) no semantic integration of Decision Architect
entities into AD Mentor. That said, it is possible to use general-purpose relationship
links such as “trace” to connect Decision Architect decision elements (e.g.in the
relationship viewpoint) to problem and/or option occurrences in ADMentor solution
spaces. The Relationship viewpoint in Decision Architect is recommended for such
integrated, hybrid use of the two architectural decision modeling add-ins.

Why does the “Create Solution Space from Problem Space” menu command
omit instantiation of some connectors in my Problem Space?

EA prohibits the automated creation of some connectors that can be created
manually in the user interface. E.g. add-ins cannot create Association connectors with
a Package as a target.

How can I find out which problem occurrences have been created from the
problems in my problem space?

Right click on the problem in question and select “Find in all Diagrams” (Ctrl + U).

9 Known Limitations and Issues (ADMentor Version 1.1)

The commands “Establish Dependencies from Problem Space” and “Create Solution
Space from Problem Space” save all currently open diagrams before execution.
Adding Option Occurrences that addresses a Problem Occurrence vie “Establish
Dependencies from Problem Space” does currently not update the state of the
Problem Occurrence.

“Establish Dependencies from Problem Space” may terminate EA under some non-
reproducible circumstances. Until now, data loss in the affected project file due to this
bug did not occur.

The XML files generated by “Tailor Problem Space” may contain more information
than visible in EA after importing the file. This could lead to leaked confidential
information in some rare cases.Importing a tailored XMl into the project that was used
to export the file can lead to unexpected results — imported diagrams contain all
original elements, even the ones that have been filtered out.

10 The AD Mentor UML Profile

10.1 Diagram Types

Description Available Stereotypes
Problem Space Models abstract problems and known  Option
solutions. Problem

Problem Space

Solution Overview Models the decision process in a Option Occurrence
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concrete project using both solutions

from the Problem Space as well as
specific Problems and Options
defined for this project.

Problem Occurrence
Solution Space

10.2 Element Stereotypes

Description

Problem
Option

Problem Occurrence

Option Occurrence

A problem that may arise during a project.

A possible solution for a problem.

A concrete problem that arose during a project and had/has
to be addressed.
A potential, chosen or neglected solution to a concrete

problem.

10.3 Package Stereotypes

Description

Problem Space
Solution Space

Bundles Problem Space items
Bundles Solution Space items

10.4 Connector Stereotypes

Source Connector Target Description
Problem Option An option is a possible
Problem Occurrence el IEHREE 2] Option Occurrence solution for a problem.
Points to problems that
Problem Problem . .
arise due to the existence
Problem Occurrence . Problem Occurrence
) Raises of another problem or the
Option Problem - .
. decision to use a certain
Option Occurrence Problem Occurrence option
Points to options that may
Option Option be preferable when the
Suggests

Option Occurrence

Option
Option Occurrence

Option
Option Occurrence

Issue
Requirement
Option Occurrence

Problem Occurrence

Requirement

Requirement

Conflicts With

Bound To

Challenges

Overrides

Positively
Assessed By

Negatively
Assessed By

Option Occurrence

Option
Option Occurrence

Option
Option Occurrence

Option Occurrence
Option Occurrence
Option Occurrence

Problem Occurrence

Option

Option

source option has been
chosen to solve a problem.
Points to options that
should not be considered
when the source option
has been chosen.

Points to options that
should be used when the
source option has been
chosen.

Denotes that a taken
decision should be
reconsidered.

Denotes that a decision
has been reconsidered.
Marks that an option is
assessed positive with
respect to the source
requirement (QOC)
Marks that an option is
assessed negative with
respect to the source
requirement (QOC)
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10.5 Tagged Values

Description Type Stereotypes

Intellectual Intellectual Property Rights (IPR)  String Problem

Property Rights for model element, e.g. Option
confidentiality level and copyright
statement.

Knowledge Reference to the cited source String Problem

Provenance Option

Organizational Sphere of influence of the Enum: Problem

Reach problem/option, e.g. entire Global,
company (enterprise architecture), Organisation,
single project or (sub-)system Program,
under construction. Project,

Subproject,
Business Unit,
Individual

Owner Role String Problem

Project Stage Gate in gate model, refinement String Problem
level in incremental and iterative
design etc. (stage in which this
problem is typically tackled)

Refinement Level  The abstraction level on which this  String Problem
problem typically occurs

Stakeholder Roles People with an interest in this String Problem
problem (note: different from
accountable person, owner role)

Viewpoint e.g. one of the 4+1 views on String Problem
software architecture, or one of
the Rozanski/Woods viewpoints

Problem State Decision making status (in Enum: Problem
solution space) Open, Occurrence
This value is derived from the sum Partially Solved,
of the option states of options that  Solved,
address this problem. Not Applicable

Option State Status of option evaluation (in Enum: Option
solution space) Eligible, Occurrence

Tentative,
Chosen,
Challenged,
Neglected

Decision Date When the decision was taken. Date Problem
This field is automatically set by Occurrence
AD Mentor when the Problem
Occurrence’s state changed to
“Solved” the first time.

Revision Date Date when this model element Date Problem
was last revised (or has to be Occurrence
revised in the future)

Due Date Until when should this problem be Date Problem
decided Occurrence

10.6 Usage of General Properties
Description Type Stereotypes

Alias Short name of problem/option,  String Problem
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synonyms Option
Role Not used String Problem Occurrence
Option Occurrence
Keywords Topic tag String Problem
Option

Problem Occurrence
Option Occurrence
Author Creator of model element String Problem
Option
Problem Occurrence
Option Occurrence
Language Not used Enum Problem
Option
Problem Occurrence
Option Occurrence
Status Editorial state String Problem
Option
Problem Occurrence
Option Occurrence
Complexity Technical risk, effort for/of String Problem
decision making Option
Problem Occurrence
Option Occurrence
Difficulty Not used String (shown by EA in
Package Browser,
but not in Properties
views)
Priority Not used String (shown by EA in
Package Browser,
but not in Properties

views)
Version Editorial version (knowledge String Problem
engineering, document level) Option

Problem Occurrence
Option Occurrence
Phase Not used (or knowledge String Problem
engineering phase) Option
Problem Occurrence
Option Occurrence

11 More Information

e Conference paper:

o 0. Zimmermann, L. Wegmann, H. Koziolek, T. Goldschmidt, Architectural
Decision Guidance across Projects, Proc. of. IEEE/IFIP WICSA 2015

e Website at HSR FHO
o https://www.ifs.hsr.ch/index.php?id=13201

e Contact:
o Olaf Zimmermann, ozimmerm@hsr.ch

© Lukas Wegmann, Olaf Zimmermann, HSR FHO 2015. All rights reserved.
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